Can I use ~sedna presenter on macOS Mojave (10.14)?

            Yes, ~sedna presenter 5  is supporting macOS Mojave (10.14).

            But please notice that ~sedna presenter 5 is a paid upgrade.

            Licenses with a valid software maintenance plan are able to update directly to ~sedna presenter 5.

            For more information about an upgrade please click here.

            Updated: 09 Nov 2018 03:44 PM
            Helpful?  
            Help us to make this article better
            0 0